Jump to content

Can-am Defender Brake Squeal


Dan
 Share

Recommended Posts

After 60 hours on my Can-Am XMR I have started to develop a bad brake squeal on my rear brakes. It sounded so bad I had my mechanic check it out because I swore I had a faulty wheel bearing or needed to use a greaser tool to lube my bearings again.

If you have experienced this it sounds like metal on metal so bad you swear damage is occurring every time it happens. Mine only happened in reverse at about 3-5 mph. The bearings appeared to be just fine upon inspection so my mechanic swears it’s a brake issue.

Apparently this is fairly common with Defenders and Can-Am in general using metallic brake pads. Has anyone experienced this? What did you use to fix it with real results? 

Link to comment
Share on other sites

My cousin and I both experienced it on our hd10 max's.... started at about 20 hours for both of us ... but we live in central Missouri with extreme valleys we run.. so we use our breaks a little heavier than most ... havent messed with it yet just goin to replace with a better brake pad when there ready to be replaced ... if anyone has fixed the squealing I would also love to know what u went with to fix it 

  • Thanks 1
Link to comment
Share on other sites

I have the same thing that just started at about 30 hours. I mainly ride around my house which is completely flat so I'm not hard on the brakes at all. Sounds like we need to find a better replacement brake pad.

  • Thanks 1
Link to comment
Share on other sites

My brakes were real noisy after I first purchased it.  I wasn't sure if there was just a ton of dirt/dust locked in or what.  It doesn't seem as bad now, but I did quite a few hard stops to clean 'em.  I've read some good reviews on the Race-Driven set: https://www.ebay.com/itm/Brake-Pads-fit-Can-Am-Defender-HD10-2016-2018-Front-and-Rear-by-Race-Driven/352271324095?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m1438.l2649

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

I stopped by the dealership today to ask about this.  I have less than 50 hours on mine and started noticing it a couple of weeks ago.  Mine is garaged and used mostly to drive around the neighborhood and to the dock in southern Missouri.  I also asked about it lunging forward when I come to a stop, usually in low gear.  Is this a common thing also?

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...