Jump to content

Jay from PA


Jay from PA
 Share

Recommended Posts

I love my 19 Defender xmr max but not having much luck with it. Got it stuck in a mud hole the first month, and broke the front driver side axle. The shop did a fantastic job fixing it. They picked it up at camp fixed the axle, did a full service, and delivered back to camp for the next weekend. It sat parked all winter not to be rode again until camp reopened. It shit the bed on the trails the first ride.  Speedo’s jumping around, it sputters and the speedo would stay at zero while moving with the odometer not registering. I delivered back to the dealer on Memorial Day suggested by the salesman because service was off for the holiday. Called first thing Tue. Morning to let the service tech. Know what the issues were when he informed me that they were back logged and wouldn’t be able to touch it till July. I have a 5 year warranty that I purchased that doesn’t mean squat, because I willing to fix it myself at this point. Any suggestions would be greatly appreciated... 

 

Link to comment
Share on other sites

Sorry to hear that you had problems when you got stuck but you also said they fixed it for you. That was last fall and this week you have another problem that you are unhappy with because you can't get service because of a back log at the same dealer.

The problems you describe will likely require the dealer to run BUDS to diagnose whether you have an ignition problem, ECM, spark plug, injector problem or possibly water in the fuel (ethanol is known for attracting moisture) from sitting since last fall. Your 5 year warranty dosen't guarantee you a spot at the front of the line so unless you can find a dealer with a shorter lineup or provide you with a loaner, I am afraid it is what it is!😟

  • Like 1
Link to comment
Share on other sites

I agree with Andy BUDS may be needed. It sure sucks but it also sucks for all the others that have toys sitting in the shop. I always recommend to people buying from a dealer with a good reputation rather then being brand specific.  When I’m buying if the shop seems a little like I’m just a number then I usually won’t buy from then. Usually cause I like to wrench. If it’s a good shop they will be busy busy during  the time you need them. Things don’t break in the off season.
Sounds like they are trying pretty hard. picking up and delivering into your camp was nice of em for a broken axle in a mud hole. 
Warranty issues can be a bit of a b though. Some times it’s outa the dealers hands. Hope they fix it for you or you can find the issue yourself. I’d probably be checking all my harnesses and connections over a cold one. Could be as simple as loose harness  Sure sounds like it could be electrical or fuel to me. Did it go into limp mode? I’d also dump all fuel including lines and inspect filter. Yes it sucks being under warranty and having to fix but if it gets you on the trails then have at it. 

Link to comment
Share on other sites

8EB51FB0-7030-49C4-828F-D72AD7BB32A0.thumb.jpeg.703785eaf3dde6e103eb156f7c805906.jpegThanks Hk, I did all the checks that I could in the grass. I pulled the speed sensor and cleaned it, checked all the harness connections on the driveline and was even going to buy a new speed sensor to try that. I wasn’t knocking the dealership, I just needed a direction to point at. I do believe it’s a common problem that everyone here will experience at some point. Hopefully this will help someone down the road. No troubles on the display but runs limp but not in limp mode with the speedo jumping around is going to be a common question in the future. I just spanked mine a little harder than most. So I have no complaints about breakage. And, the good news is,  the salesman that I know at the dealership is going to hook it up tomorrow. I may get that answer sooner than I expected.

Link to comment
Share on other sites

Well Jay from PA, I'm here to say.... WELCOME!! 

As for the electrical??? GOOD LUCK!!! As for the fuel?? While Ethanol attracts water... Methanol/Alcohol will evaporate it from the fuel... common problem in swampers I would think... You can usually get some in small amounts from your local hobby store. RC fuel. Won't hurt to add heck... a cup to a tank and shake up the tank (a ride around) and if it was water..... gone in no time... better yet would be find a dirt tracker and get some 100% Methanol. Bought many race cars for a deal after somebody pressure washed a rig to sell.... the rig stumbles..... we buy for a deal.... then add Methanol to the tank and win the show..... DOH!! 

But to combat that.... buy CLEAR FUEL.... Not super easy to find... and not cheap... but will save the headaches on your rig as well as your gas powered lawn tools

Link to comment
Share on other sites

Thanks CG. Everything seems to working just fine. However I won’t be trying that hole again. The mid was over my lap in the middle, and the ramp out was more of a wall that stopped me dead.  Sad to say that it took a ranger north star  tied to a ranger crew while I winched a tree to get out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...