Jump to content

HD10 engine issues


Mossyoak
 Share

Recommended Posts

Wondering if anyone out here has had any ongoing engine codes/limp home issues, my 2019 HD10 hunting edition has been to the shop on 3 separate occasions with the same 3 codes, P160E, P060E and P1613. First trip, dealer change air filter, 24hrs later back at dealer, they then changed throttle body, now 1 1/2 months later their changing the ECM

Link to comment
Share on other sites

Sounds like they are just replacing the parts involved with the error in order of cheapest to most expensive to replace.  Given those error codes they likely fixed it.  Only thing sounds like they didn't change was the electrical harness between ECM and the throttle body.  Hopefully they got it.

Link to comment
Share on other sites

  • 1 year later...

just wondering if you got all your issues sorted out.  I have a 2020 Defender throwing the same codes as well as P1615.   Mine heads to the shop in 2 weeks.  Hopefully I can figure it out before it goes there 

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...
On 4/9/2021 at 4:03 PM, Farrell said:

just wondering if you got all your issues sorted out.  I have a 2020 Defender throwing the same codes as well as P1615.   Mine heads to the shop in 2 weeks.  Hopefully I can figure it out before it goes there 

my 2020 defender is showing the same code P1615.  What was the outcome?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...