Jump to content

smart lock message on dash


RangerBob316

Recommended Posts


  • Member ID:  305
  • Content Count:  24
  • Reputation:   5
  • Joined:  12/27/2019
  • Status:  Offline
  • Last Seen:  

Anyone ever see their check engine light come on, and a message that reads "check smart lock system".

Had this happen over the weekend while in 4x4, Mud mod "ON", front and rear diffs were not locked. 12" of mud and I had all four wheel spinning at low RPM. 

Things seemed to be working fine, except the error. 

Any ideas? 

2018 Defender Max Xmr 

Edited by RangerBob316
Link to comment
Share on other sites


  • Member ID:  133
  • Content Count:  686
  • Reputation:   151
  • Joined:  04/24/2019
  • Status:  Offline
  • Last Seen:  

Have you checked your operators manual, it may explain the message there. Smart lock uses inputs from different sensors to determine how much bias it needs to apply to each of the front wheels, so it may have detected something that was outside its parameters. My 2018 Shop Manual Supplement does not cover the Smart lock system.🤔

Link to comment
Share on other sites


  • Member ID:  305
  • Content Count:  24
  • Reputation:   5
  • Joined:  12/27/2019
  • Status:  Offline
  • Last Seen:  

Dealer said that with my overhead audio ON, the stater isn’t producing enough power to run the machine. Just so happens the smart lock system threw a code. 
That’s very frustrating. If that’s true, I’ll be screwed at night if I’m using my light bars in the mud. 

Link to comment
Share on other sites


  • Member ID:  133
  • Content Count:  686
  • Reputation:   151
  • Joined:  04/24/2019
  • Status:  Offline
  • Last Seen:  

Thanks for the reply and good to hear it was nothing more serious.

The stator on the 2019 and older machines is a 650 watt and it dosen't produce the full charge unless you are above 4000 RPM so depending on your riding style you are not at maximum charge most of the time.

I checked the voltage regulator part number and it is the same for the 2020 as the previous machines but I have not checked availability, price or retrofit for the 850 watt stator that comes in the 2020's and newer.

Some members have added more battery storage capacity by adding a second battery of the same size 20 or 30 Amp simply by wiring a second battery in parallel and the factory add a battery kit contains more, like a diode etc that prevents the two batteries from going dead at the same time but it is more costly. Others have gone to a larger battery which will fit (in the original location) like the Odyssey which increases your Amphr rating as well as CCA. This option is a plug and play, remove the stock and replace with the larger battery, no wiring etc. This would be my choice if I felt I needed to do so.

If you use your stereo day and night than adding a larger or second battery will delay the voltage drop because of the larger storage capacity but not solve it completely unless you reduce your DC amp load ocassionally to provide a top off charge or top off with a battery charger or solar panel when not in use. A simpler solution is to manage your charging load by switching off unnecesarry items to allow the battery to fully recharge. The ECM monitors the system voltage and will increase the idle RPM if it senses low voltage to try and prevent a dead battery. If I use my winch(s) I make sure all accessories are off and I run the engine RPM higher, if not in gear, to provide amperage for the winch. After the job is complete I make sure I provide sufficient time to recharge the battery.

My emergency power pack is a 18ma boost pack which can easily start a dead battery situation since there is no other way to start the engine. I have used it to start a sxs and quad on different trips with dead batteries. FYI😉

Link to comment
Share on other sites

  • 1 year later...

  • Member ID:  1,078
  • Content Count:  2
  • Reputation:   0
  • Joined:  06/20/2021
  • Status:  Offline
  • Last Seen:  

This just happened to me. No over head audio or aftermarket lights. Don't even hear the machine switch to 4x4 like used too. It's a 21 defender xmr. Any ideas as I wish to continue to ride els it's going into shop again. This machine has been nothing but a head ache every time we go out it has to go back to the shop. Hanger bearing, drive line and there was no scratches on the drive line and the shop said they never seen such a thing but now have. Front drive line fell off for no reason. I know it's a xmr and alot of people run them through some deep mud water and what not. The deepest I've had mine was maybe 12 inches

Link to comment
Share on other sites


  • Member ID:  1,078
  • Content Count:  2
  • Reputation:   0
  • Joined:  06/20/2021
  • Status:  Offline
  • Last Seen:  

The same issue has just happened to me. It's a 2021 defender xmr. I do not have any aftermarket lights or radio. Checked the connections and seems to be good. I've had nothing but bad luck with this machine and not ever hard on the machine. In the past 3 months hanger bearing,main drive line bent and dealership can't explain how or why as there were not scrape marks on drive line, front drive line fell off, speedo falling off. Tired of having to put money into a machine every time we take it out. Yes the machine is back at the dealership for the smart lock system. If any one can help and have me try something else out I'd appreciate it as would like to still ride. Thanks for your times and inputs 

Link to comment
Share on other sites

  • 1 month later...

  • Member ID:  1,173
  • Content Count:  1
  • Reputation:   0
  • Joined:  08/10/2021
  • Status:  Offline
  • Last Seen:  

I have a 2018 Defender xmr hd10 with the same problem. When I switch from 2 x 4 to 4 x 4 and back, the check smart lock message appears. When I shot it of for a couple of minutes, the message is gone, but next time,  same thing again. 

Link to comment
Share on other sites

  • 1 month later...

  • Member ID:  1,262
  • Content Count:  3
  • Reputation:   0
  • Joined:  10/06/2021
  • Status:  Offline
  • Last Seen:  

I have a 2020 XMR HD10 with overhead sound bar and just had it happen yesterday.  Was cruising along but seemed to happen when I hit diff lock and was making a tight turn.  The machine would sort of jerk and throw the message.  Anyone else figure this out?

Link to comment
Share on other sites

  • 4 weeks later...

  • Member ID:  1,312
  • Content Count:  1
  • Reputation:   0
  • Joined:  11/02/2021
  • Status:  Offline
  • Last Seen:  

Where exactly is the smartlock plug? Trying to check to make sure it’s locked in but cannot find the plug or a diagram anywhere 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...