Jump to content
  • 0

Dps power steering not working


Newfie
 Share

Question

My Dps power steering suddenly seems to have stopped working on 2017 HD 8 defender ..any suggestions or ideas to why or has anyone has this issue ?

any help would be greatly appreciated!

 

Bill

 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

1) Check fuse F2 in the fuse box under the hood it is the one on the bottom row on the left and is 40A.

2) Check that your battery connections are clean and the voltage at the DPS should be the same as a good battery at least 12.6 if the engine is not running and higher if the engine is idling. You will need a voltmeter to check this.

3) Check the ground wire to make sure you have a clean contact.

4) Turn the ignition key on and try turning the steering slowly the power assist should work, if it doesn't you may have a problem with the DPS itself.

5) If you were driving when you noticed a loss of power assist you may have got the DPS hot and if this happens it derates the amount of assist until it finally quits. You may have seen a DPS overheat on your guage. If this happens the power assist returns once the unit has been cooled down into the normal range.🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...