Jump to content
  • 0

2020 Defender HD10 Not always starting


Defender Bender

Question


  • Member ID:  2,437
  • Content Count:  1
  • Reputation:   0
  • Joined:  01/22/2024
  • Status:  Offline
  • Last Seen:  

I have a 2020 Defender HD10 that usually starts but sometimes after running it for a while after i shut it off and try to restart it doesn't want to start. Battery has full voltage. It tries to crank but barely turns over, tries several times and then stops. Usually if i leave it sit for a while it starts right up again.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

  • Member ID:  338
  • Content Count:  265
  • Reputation:   72
  • Joined:  02/07/2020
  • Status:  Offline
  • Last Seen:  

First thing to check is for vacuum in the gas tank. Next time it won't start, open the gas cap then try. If it starts like normal, then that means one of the check valves on the vent lines for the gas tank is bad (or the line has something plugging it) and not allowing air in as gas is pumped out.

Link to comment
Share on other sites

  • 0

  • Member ID:  2,441
  • Content Count:  3
  • Reputation:   1
  • Joined:  01/31/2024
  • Status:  Offline
  • Last Seen:  

I have a new HD9 and had/have a ‘similar’ issue.  It only starts intermittently when in Park or Neutral - UNLESS I have my foot on the brake.  It starts every time when I do - also good for safety of course.  I asked the dealer and they said it was a known issue with that model and not to worry about it?  Seeing it’s a small thing I haven’t bothered following it up.  

Link to comment
Share on other sites

  • 0

  • Member ID:  338
  • Content Count:  265
  • Reputation:   72
  • Joined:  02/07/2020
  • Status:  Offline
  • Last Seen:  

23 hours ago, Mat said:

I have a new HD9 and had/have a ‘similar’ issue.  It only starts intermittently when in Park or Neutral - UNLESS I have my foot on the brake.  It starts every time when I do - also good for safety of course.  I asked the dealer and they said it was a known issue with that model and not to worry about it?  Seeing it’s a small thing I haven’t bothered following it up.  

It sounds like a failing safety switch. 

I know on my '19 that sometimes when put it in Park, it doesn't always settle in so I have to use the brake or rock the machine forward and backward until it 'clicks' into Park.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...