Jump to content
  • 0

PPS Fault


Deer Haven dude
 Share

Question

I recently removed my Warn Winch from my 2021 Defender Pro XT (it was damaged accidentally) and the next time I tried to turn it on I get a “PPS Fault” error and it won’t start. I don’t know if they are related or not, maybe a coincidence? I checked and verified all fuses are OK and tightened the battery terminals but no change. Thoughts or suggestions on what to try next? Trying to avoid a dealership trip as it requires renting a car hauler! 

Thanks

 

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Just throwing ideas out, but did you wrap up the wire ends from the winch? Did they touch and arc at all during uninstall?

 

Have you tried unhooking the battery for 30 minutes then re-hooking it up? Might be worth getting the battery tested. I've read that the PPS Fault is usually from a dead battery issue.

Edited by Steelslinger
Link to comment
Share on other sites

  • 0

Thanks. I’m pretty sure the ends of the wires did not touch or arc. I left a battery minder attached so I know at least it will be fully charged next time I’m there. I called a dealership and they suggested it was likely just a bad battery. The volt meter on the dash showed 9-10 volts which they said would not be enough to start the engine and is indicative of a bad battery. I plan to see if the dealer will provide me a new battery to try since it would be under warranty. I’ll respond once the problem is resolved. Thanks again.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...